Intermittent disconnects, connectivity issues

Hello,

Looking for any feedback about connectivity issues/random disconnects in the last week or so. If this happens to you with irritating frequency, or you have noticed any patterns, make a note here.

It seems to be a downside to the CDN I’ve placed tubes behind. May just forego CDNing specifically the socket traffic to prevent these D/Cs since we’re not exactly overwhelmed anyways and the objective of these hosting changes is to improve our stability, not reduce it. :shepface:

More changes coming in the next few days.

I’ve had it happen once, late at night, but it’s never consistent. I know Pen was experiencing it as well, at least once.

edit: on a different day, not at the same time as me

Because, yeah. We only talk when there’s a problem. Usually late at night. When I’ve been drinking.

But cams are borked.

Reminds me of the 0 cams per row thing, only it’s not that.

Thought you should know. Hope you’re doing well. Goodbye.

Having occasional disconnects today too

Same

I like keeping everything consistently behind the new CDN service.

A side effect of using this CDN is that when there is a system/code change made upstream, we are impacted in the form of random disconnects on our persistent “socket” connections.

Thank you for reports. It is clear that these disconnects happen annoyingly often enough now that there should be some action.

To compromise, I was thinking of implementing a reconnect / session resume to make these hiccups less abrasive, and so that app state/message history continuity won’t be lost. I think that is something I can tackle early in the AM on Saturday/Sunday.

There is a solution in place now for reconnecting, but I am still sorting out a little weirdness today :slight_smile:

edit: Alright, clear cache, this is hopefully a lot more consistent now.

hey still not able to connect at all to goontu.be. jskz I know we worked on it last week, but it still eludes me and google. so idk!

if anyone wants to help ts me here:

privacy

this is the error i encounter when trying to connect.

more info:

privacy2

I can take more screenshots but basically I have tried so far:

  1. flushing dns

  2. clearing chache

  3. disabling firewall

  4. disabling antivirus

  5. resetting the google fiber

  6. trying a different browser

  7. waiting a bit

More details:
I can connect to goontube using my phone and ethan’s computer with a hardwire connection. It is only this computer.

i appreciate any and all suggestions <3

What happens when you click on the “Advanced” button? Is this an option to continue to the site?

What’s happened is:

A few weeks ago, I shuffled around a few of my servers. The old goontu.be IP address is now pointing to a server I use for beta/development.

You still have a hosts file entry on your computer or some other override which is forcing you to resolve goontu.be to the old IP address, so when you connect, your browser throws a warning that this server isn’t what it claims to be (because goontu.be != beta.goontu.be)

We went through your hosts file together and you did have a specific entry for goontube, but I thought we removed it. :thunk:

we did!

idk how to get back to that file, but i can take a screenshot.

remember, we deleted it and then tried again and it didn’t work. went back to the file to confirm it was gone and it was.

Maybe i can write a new line with the correct server address?

nope.

Try these lines in your hosts file:

104.26.5.181 goontu.be www.goontu.be
172.67.68.43 goontu.be www.goontu.be
104.26.4.181 goontu.be www.goontu.be

hosts

Restart browser, hope for the best.

goonspeed!

can you tell me how to get, how to get to the host file?

C:\Windows\System32\drivers\etc

ty!

didn’t work :frowning:

i know this is kindof a dumb thing, but have you tried typing out the full url rather than just goontu.be?

https://goontu.be/

or https://www.goontu.be

Also I’ve seen similar problems arise if your system clock isn’t set properly. Do you have your system clock set to auto and is the timezone correct?

Did you guys look into the HSTS aspect of that error, by chance?